Geany 0.15 Debianizado Para Ubuntu

por | 27 octubre, 2008

Hola, hace ya unos días que salió a la luz una nueva versión de Geany, la 0.15. Como he visto que todavía no ha salido un deb en Getdeb me la debianicé para mi y os dejo un enlace de descarga para que lo podáis disfrutar. En ppio. sirve para Ubuntu Hardy Heron y para Intrepid Ibex.

Para el que no sepa que es Geany sólo comentar que es un IDE muy ligero pero bastante completo para aquellos programadores en lenguajes que nos gusta hacer nuestros pinitos pero sin tener un IDE muy pesado o complejo, también es ideal para aquellos programadores que posean un PC bastante limitado.

Nos permite programar en lenguajes como C, C++, Java, Ensamblado, D, FreeBasic, etc; en lenguajes scripts como: Makefile, Perl, PHP, Python, etc; también en código gettext, lateX, y unos cuantos más. Además nos viene con un completo conjunto de características de edición, y su uso es muy sencillo.

Si queréis probarlo os dejo el enlace de descarga del paquete debianizado que he hecho.

DESCARGAR GEANY PARA UBUNTU 32 BITS

Saludos :-h

9 pensamientos en “Geany 0.15 Debianizado Para Ubuntu

  1. Cristian

    Juas… vos siempre tan generoso. Muchísimas gracias por el paquete, estoy seguro que a más de uno le servirá.

    Un saludo!

  2. loboenlunallena

    yo lo tengo pero no puedo compilar en freebasic.

    como le instalo el soporte de freebasic a ubuntu 9.04? encima es AMD64

    saludos

  3. Cristobal

    Hola, aqui tienes un video de cómo hacerlo

    Pero antes de hacer todo lo que pone en el video prueba primero instalando desde synaptic la libreria libfreebasic, luego desde Geany crea un fichero .bas, un hola mundo para probar, compila y ejecuta.
    Si no te funciona haz lo que se ve en el video.

    Ya me cuentas qué tal

  4. loboenlunallena

    muchas gracias por la rapida respuesta. el video ese fue lo primero que vi y lo estaba siguiendo al pie de la letra hasta que busca en synaptic “libfreebasic” y yo no tengo ese paquete.

    me doy cuenta que es ubuntu 8.04 por el fondo de escritorio.

    despues vi unos cuantos foros e instale un libfreebasic que era para i386 pero nada.

    despues instale tambien el que esta en el link q me pasaste (que tambien es i386) y tampoco. cuando corro el geany y creo un archibo.bas como dice el video me tira error al ejecutarlo o compilarlo.

    no se la verdad si es que directamente no se puede instalar en jaunty AMD64

    saludos y gracias por preocuparte por mi problema

  5. Cristobal

    Lo acabo de probar en Ubuntu con getdeb y me funciona, me parece que freebasic sólo es para 32 bits, no hay soporte para 64 bits.
    Puedes tener tu Ubuntu instalado en 32 bits y probar a ver.
    O puedes instalar Gambas, un proyecto que pretende suplir a Basic, muchos dicen que es muy bueno.

  6. loboenlunallena

    ahh ahi me parece.

    voy a probar gamas. mi idea es poder programar en basic (en lo posible q sea 100% compatible con qbasic)

    muchisimas gracias por la ayuda.

Los comentarios están cerrados.