Gimp 2.5.3 Debianizado Para Ubuntu Hardy

por | 25 Agosto, 2008

Hola, después de día y medio intentando debianizar el Gimp por fin lo he conseguido. Me ha costado mucho llegar a buen puerto, el primer obstáculo que he encontrado es debianizar las librerías babl y gegl, que conseguía casi el objetivo, pero incomprensiblemente en los deb no me copiaba los ficheros, no se si porque tenían algún error los make o porque no me aclaré para debianizar multipaquetes. Al final vi que ya estaban debianizados en Mamá Debian, así que me los bajé y los instalé sin problemas

Luego debiqanizarel GIMP en sí ha sido la repanocha, al hacer el make me daba error de no encontrar ciertas librerías donde debían estar alojadas, buscando por la web de GIMP encontré que había que aplicar un parche o patch, al ppio. no tenía ni pajolera idea de cómo aplicarlo, hasa que al final sonó la flauta. Cuando ya me disponía a debianizarlo tuve que cambiar el archivo rules como unas 8 veces, que si el info, que si no me calculaba todas las dependencias (se dejaba las de python)… Y bueno al fin lo he conseguido

Pero bueno os dejo de mis rollos que poco os deben importar Pasemos a cómo hay que instalarlo. Deciros que lo he debianizado para que os funcione sin que os desinstale la versión 2.4 que tenéis instalada bien de los repositorios o bien la que hay en Getdeb, así que vais a tener dos GIMP, ¡a ver si eso lo podéis tener en windows!

Lo primero os lo descaergáis del siguiente enlace:

DESCARGAR GIMP 2.5.3 DEBIANIZADO PARA UBUNTU HARDY 32 BITS

Cuando os lo hayáis bajado y lo descomprimís, acceded a la carpeta recién descomprimida y veréis que tenéis unos cuantos ficheros, en concreto son 8. Instalad primero los que hacen referencia a babl y a gegl (gegl es una nueva característica que incorpora el nuevo GIMP, basada en OPENGL y con la que podréis configurar muchos efectos a vuestras imágenes). Los podéis instalar con Gdebi o desde terminal con la orden:

sudo dpkg -i gegl_0.0.18-1_i386.deb libgegl*.deb libbabl*.deb

Si todo ha ido bien sólo os falta instalar el GIMP, que es el fichero gimp5, lo podéis hacer con Gdebi tranquilamente

Bien ya está instalado, ahora sólo queda un pequeño detalle que no he podido solucionar de ningún modo para no tener que hacerlo vosotros a mano, es crearos un acceso directo al programa, pero esto es muy simple de hacer. Acceded a Sistema->Preferencias->Menu Principal, en la nueva ventana que se os abre, a vuestra izqda., marcad la opción Gráficos, y a vuestra derecha presionad en el botón Elemento Nuevo, en la nueva ventana rellenadla como os pongo en la siguiente imagen.

gimpscreen

GIMP ACCESO

Ya esta, cerráis todo y en Aplicaciones->Gráficos->GIMP2.5.3 podréis ejecutar vuestro nuevo GIMP si no pasa nada raro. En todo momento podréis ejecutar vuestro GIMP 2.4 como lo haciaís normalmente.

Os dejo una imagen del nuevo GIMP corriendo en mi Ubuntu.

gimp

MI GIMP

¡Por favor, si al instalarlo tenéis problemas de dependencias informadme de ello para que pueda rebajarlas de versión!

Saludos :-h

11 pensamientos en “Gimp 2.5.3 Debianizado Para Ubuntu Hardy

  1. sanatas

    “Al final vi que ya estaban debianizados en Mamá Debian.” Si es que ande este debian ….

    P.D. ¿Has recortado lo que sale en RSS? porque desde hace unos cuantos post ya no me sale todo el contenido.

  2. Cristobal

    Sí, ande este debian, pero la unstable…
    Sí he recortado lo del lector RSS, pero si queréis que lo ponga como estaba me lo decís y lo cambio
    Por cierto, en GV4 no creo que se pueda instalar, pero en la V5 supongo que sí, si alguien quiere probar….

  3. JCarlos

    me da un error de dependencias, al instalar el ultimo paquete, el de gimp, con la libreria libasound2, pero si que la tengo instalada. ¿por que puede ser?
    Gracias y a seguir asi

  4. Cristobal

    hola JCarlos, lo más seguro es que tengas una versión anterior a la que tengo yo. Ahora no puedo arreglarlo, espero que a las ocho y media de la tarde cambiarlo. ¡Paciencia!
    Y gracias a ti

  5. JCarlos

    Por si te sirve La version con la que da problemas es la que viene con Ubuntu Hardy la 1.0.15-3ubuntu4.

  6. Andrés

    al instalar desde GDebi el Gimp 2.5.3, después de instalar las librerías, me aparece: Error: Dependency not satisfiable: libpoppler-glib3, y al buscar en Synaptic, no aparece, ¿DEbo descargarla desde algun lugar en especifico?

  7. Cristobal

    @JCarlos y @Andrés, ya lo he modificado, volved a bajarlo e instalad sólo el paquete del GIMP, a ver si ya podéis.
    Perdón por las molestias, pero esto es lo que pasa por añadir repositorios de launchpad

  8. Cristobal

    Las gracias son recíprocas JCarlos. Sí recuerdo la canción esa tan famosa de Rubi, he leido el artículo y parece ser que le mola el blues, eso esta muu bien. Veré si puedo escuchar el disco de algún sitio para poder juzgarlo

  9. Pingback: Unos Cuantos Plugins Para El Gimp 2.5.3

  10. sanatas

    Gracias por poner el RSS completo, es que uso liferea para leer unos cuantos blogs y me ahorra el tener que estar abriendo páginas en iceweasel.

Los comentarios están cerrados.