Mi Repositorio En Launchpad

por | 1 abril, 2010

¡Hola peñaaa! Bueno traigo noticias frescas Viendo que con JDownloader se me sugirió hacerme un repositorio en Launchpad para colgar todos los paquetes que debianizo resulta que me he decidido ha hacerlo y he creado mi propio repositorio para que esté disponible para toda la peña.

Me ha costado bastante hacerlo porque para crear la firma legal del repositorio es bastante costoso de tiempo hacerlo, y luego no tenía claro si tenía que construir yo mismo los debs o los creaba Launchpad al subir las fuentes, al final Andrew de Webupd8 me ha aclarado la duda ¡Gracias Andrew por el cable!

Por ahora sólo he subido una actualización de las librerías MuParser, a la 1.32; y todo ha ido perfecto.

El repositorio lo tengo enfocado hacia la actualización o mantenimiento de programas que no se encuentren en los repositorios de Ubuntu relacionados principalmente con las matemáticas y la programación, pero estoy abierto ha añadir programas que me resulten interesantes

El repositorio ya está totalmente activo en uso. Para añadirlo abrir terminal y escribid:

sudo add-apt-repository ppa:lopeztobal/maths

Eso es todo. Espero que tengáis paciencia Tengo pensado subir Geogebra, MathPipper, Octave 3.2.4, etc, etc.. Si me dejan también subiré JDownloader.

¡AAhhh!! se me olvidaba el repositorio sólo es válido a partir de Lucid Lynx, es que para el poco tiempo que queda para salir la nueva Lucid he decidido actualizar mi Ubuntu a Lucid porque así me supone menos trabajo al empaquetar.

Saludos

16 pensamientos en “Mi Repositorio En Launchpad

  1. seaofgrass

    Una peticion. Hace tiempo colgaste un debianizado de TED, el programa para descargar series. Ellos nunca sacan paquetes debianizados del programa, asi que me pareceria interesante.

    Un saludo y gracias por tu trabajo

  2. Cristian

    Hola Cristobal, me encantó tu página, ya es una de mis favoritas, se agradece demaciado este repositorio y que bueno que programas como Jdownloader este allí, ojala puedas agregar el programa Thunderbird 3.0, el último puesto que no he podido encontrarlo en ningún lado y yo creo que más de alguno lo quisiera tener en el koala, muchas gracias. saludos

  3. Cristobal

    Cristian este repositorio es para Lucid Lynx, no para Karmic. De todas formas puedes añadirlo de esta forma

    sudo gedit /etc/apt/sources.list
    copia la siguiente línea
    deb http://ppa.launchpad.net/lopeztobal/maths/ubuntu lucid main

    Guarda los cambios y cierra. Ahora añade la clave así
    wget -q -O- http://ppa.launchpad.net/lopeztobal/maths/ubuntu/dists/lucid/Release.gpg | sudo apt-key add –

    Luego actualiza tus repositorios con
    sudo apt-get update
    sudo apt-get upgrade

    Si esto no te funciona me temo que tendrás que esperar a lucid o bajar los que te interesen a mano desde aquí
    http://ppa.launchpad.net/lopeztobal/maths/ubuntu/pool/main/

    Saludos

  4. Cristian

    Muchas gracias, resultó todo bien, saludos!

  5. Yoyo

    Un tipo importante, con repositorio propio y todo, que será lo próximo ¿dominar el mundo? xDD

    Enhorabuena Cristobal

  6. Alejandro

    Me alegro de que ya tengas un dominio propio. Dentro de poco cambiaré el enlace del blogroll.
    Sobre tu repositorio, pues me parece que ya era hora que alguien hiciera las cosas bien (jDownloader, el paquetito de las notificaciones… joder lo tienes todo ahí xD)

    Saludos

  7. Rubén

    Hola, soy muy nuevo con ubuntu asi que pido perdón por la ignorancia, bueno, hace poco hice en el terminal un “sudo apt-get update” y me apareció esto, lamentablemente no tengo respuesta, ya que lo he buscado en google y nada.

    W: Imposible obtener http://ppa.launchpad.net/lopeztobal/maths/ubuntu/dists/karmic/main/binary-i386/Packages.gz 404 Not Found

    E: Algunos archivos de índice no se han podido descargar, se han ignorado,
    o se ha utilizado unos antiguos en su lugar.

    PD. Tengo la version Ubuntu 9.10 karmic koala

    Gracias por la ayuda.

  8. Tobal Autor

    @Ruben-> Si lees mi post al final pongo claramente que el repositorio sólo sirve a partir de la 10.04 Lucid Lynx
    Así que si lo quieres utilizar deberás actualizar tu Ubuntu

  9. Rubén

    Ok. Muchas gracias por la respuesta, lo tendré en cuenta. Saludos.

  10. andrez

    bien Tobal…… se le agradece su aporte…. animo…. con este proyecto…

Los comentarios están cerrados.