Nueva Versión De Qtoctave

por | 21 Abril, 2008

Hola, hace unos días que salió la nueva versión de QtOctave (( la 0.7.4 )), como muchos ya sabéis este programa es un frontend con el cual podemos trabajar de una forma muy cómoda con Octave, muy parecido a Matlab, y nada que envidiar a éste.

Lo he debianizado para Ubuntu, funcionará seguro con Ubuntu Gutsy y Hardy, con anteriores versiones no lo sé. Sólo los he debianizado para i386. Para 64 bits ya existen paquetes en la web del creador. Además he debianizado la utilidad de EasyPlot, creada por el mismo, con la cual podremos editar nuestras funciones gráficas desde Octave o desde Qtoctave de una forma muy amigable ( poner nombres a los ejes, rotarlos, titularlos, leyendas, etc.) También podemos exportarlas en formato imagen o pdf, por ejemplo.

Con Qtoctave obtendremos una muy cercana aproximación de compatibilidad con el maldito Matlab, aunque dependerá mucho de lo reciente que sea nuestro Octave, en Hardy Heron ya tenemos la versión 3.0 de Octave.  Con Qtoctave contamos con un editor y compilador muy completo para poder hacer nuestras aplicaciones apoyadas en código Octave.

Bien, la instalación es muy sencilla, os descargáis el siguiente tar del siguiente enlace:

DESCARGAR QTOCTAVE CON EASYPLOT PARA UBUNTU

Lo descomprimís e instaláis ambos paquetes con Gdebi. Tan sólo queda hacer que Qtoctave tenga soporte con EasyPlot, para ello abrid Qtoctave en Aplicaciones->Educación->Qtoctave, ahora id a Config->General Configuration, buscad donde pone Easy Plot, marcad la opción Use Easy Plot y en el Path poned lo siguiente:

/usr/local/bin/easy_plot

Presionad en OK, cerrad Qtoctave y volved a abrirlo, ahora en la ventana de la terminal de Qtoctave escribid sombrero(20) si os aparece una ventana con la archiconocida función 3d en la que podéis editarla y guardarla es que ya os funciona.

Qtoctave

Para los de Guadalinex V4 no puedo debianizarlo porque las librerías Qt que hay son demasiado antiguas ( igual pasa con Edgy para atrás), pero el creador del programa ha creado un soporte con binarios con el que podréis hacerlo funcionar. Tan sólo deberéis instalar antes octave y gnuplot desde synaptic, luego os lo descargáis de AQUI el que pone binario, lo descomprimís en vuestro home y ejecutad con doble click el fichero qtoctave.sh.

Si queréis el soporte de Easy_Plot podéis descargar el tar de arriba e instalar sólo el de easyplot con Gdebi y luego seguir los pasos detallados anteriormente para que os funcione con Qtoctave.

Saludos

Fuente->Qtoctave

2 pensamientos en “Nueva Versión De Qtoctave

  1. Víctor

    Disculpa, no encuentro la web del creador de easy-plot. Tienes alguna referencia más? He intentado instalar con dpkg –force-architecture el paquete de i386 y després buscar las librerias que veía que faltaban de los errores y con getlibs pero no he tenido éxito.

    Gracias

Los comentarios están cerrados.