Nueva Versión Debianizada De Qtoctave Para Ubuntu

por | 28 septiembre, 2008

Hola, hace unos días salió la versión 0.8.1 de Qtoctave y yo la he debianizado para Ubuntu Hardy Heron, necesitaréis la versión 3.0 de Octave, que la tenéis en los repositorios oficiales de Hardy Heron. Para quienes no lo sepan Qtoctave es un programa que se basa en una interfaz gráfica de Octave, para así tener un manejo más amigable de Octave, el cual es un programa que se parece mucho al Matlab. Para instalar esta nueva versión lo primero es bajarla del siguiente enlace:

DESCARGAR QTOCTAVE PARA UBUNTU HARDY HERON DE 32 BITS

Después de bajado lo instaláis con un simple doble click izqdo. de ratón sobre el fichero descargado. Lo encontraréis en Aplicaciones->Educación->Qtoctave

Si queréis un mejor manejo de las gráficas os aconsejo instalar la herramienta EasyPlot, os la podéis descargar del siguiente enlace:

DESCARGAR EASYPLOT

Lo instaláis como el anterior, para que os funcione con Qtoctave deberéis configurarlo antes, para ello ejecutad Qtoctave primero, luego os dirigís en el programa a Config->General Configuration, se os abrirá una ventana, le dáis a la pestaña Octave, marcáis la opción Use Easy Plot, donde pone Easy Plot Path lo rellenáis con la siguiente ruta: /usr/local/bin/easy_plot Luego confirmáis los cambios presionando en OK, os saldrá un mensaje advirtiendo que para que se apliquen los nuevos cambios deberéis reiniciar Qtoctave,. así pues cerrad por completo Qtoctave y lo volvéis a ejecutar. Para saber si os funciona podéis escribir en la ventana de ejecución de comandos la instrucción sombrero(20), y si se os abre una nueva ventana con el dibujo de la función sombrero dibujada es que os funciona.

No se a vosotros qué os parece, pero a mi Qtoctave me parece una herramienta muy completa y útil.

Saludos :-h

6 pensamientos en “Nueva Versión Debianizada De Qtoctave Para Ubuntu

  1. protion9

    Muchas gracias Cristobal. Leí la noticia de la nueva versión de QtOctave hace algunos días, pero no me atreví a pedirte el deb porque tampoco es que me haga falta de momento.

    Los de matemáticas teneis más programillas útiles en GNU/Linux que los ingenieros, que envidia XD

  2. Cristobal

    De nadas tio
    Supongo que te refieres al Autocad, programa difícil de crear, máxime cuando el código creo que es cerrado.
    Matlab y Mathematica aunque son de pago tienen el código de sus funciones abierto, el Derive no, pero esos problemas se solventan en Maxima gracias a una ingente cantidad de buenas librerías realizadas en Fortran y que se han pasado o medio adaptado al lenguaje C, como BLAS.

  3. protion9

    Autocad, Catia, Solidworks, etc.

    Curioso el tema porque anteriores versiones de Catia trabajaban en Unix.

    Además, tanto Catia como Solidworks utilizan OpenGL (y tienen buena culpa del descalabro y conservadurismo de la versión 3)

    Autodesk, el creador de Autocad, es también el creador de Maya, que si existe para GNU/Linux y es de lo más utilizado en animación 3D.

    Autocad es un puto cancer, es el Windows de los programas de dibujo. Llegó, se dejó piratear y una vez que todos tenían un AutoCAD en sus vidas… ¡zas! Estandar de facto, no hay posible alternativa, si quieres leer sus ficheros tienes que usar ese programa. Además es como MS Office, sacan versiones al año, por supuesto carísimas, y cambian algunos iconitos, unas pocas funcionalidades y el formato ya no se puede leer en versiones anteriores. Un dibujo con Autocad 2008 no se lee en Autocad 2000.

    Hace algún tiempo tenía la esperanza de ver más programas CAD en Linux por eso de que los fabricantes de coches están migrando… pero de momento nada de nada. Supongo que Microsoft tiene sus chanchullos para que solo se programe en esa plataforma. Miedo daría que gran parte del sector de la ingeniería y la arquitectura se pasara al pingüino.

  4. Pingback: QtOctave para Ubuntu « QtOctave un Front-End para Octave

  5. Pingback: QtOctave in Ubuntu « QtOctave un Front-End para Octave

  6. Pingback: Idas de pella » QtOctave un Front-End para Octave

Los comentarios están cerrados.